Compatible

COMPATIBLE
 
QuickSlide runs on your system

QuickSlide is one of a very small number of PowerPoint tools worldwide to have been certified by Microsoft.
It runs safely and reliably in all common environments:
Windows 10/8/7/Vista; Office 2016/2013/2010/2007, locally, on terminal servers, via Citrix.
The only requirements are the add-in for PowerPoint and, where necessary,
a central storage location (e.g. file share, SharePoint, Box).
That’s it. Deliberately no additional databases or servers.
And a multilingual user interface is no problem of course.
 

 

COMPATIBLE
QuickSlide runs on your system

QuickSlide is one of a very small number of PowerPoint tools worldwide to have been certified by Microsoft. It runs safely and reliably in all common environments: Windows 10/8/7/Vista; Office 2013/2010/2007, locally, on terminal servers, via Citrix.
The only requirements are the add-in for PowerPoint and, where necessary, a central storage location (e.g. file share, SharePoint, Box).
That’s it. Deliberately no additional databases or servers.
And a multilingual user interface is no problem of course.